Z-28 Instrument cluster hook up and connections?

Discussion in 'Troubleshooting & Diagnosis' started by gookc, Dec 31, 2006.

  1. gookc

    gookc Veteran Member

    358
    0
    Aug 9, 2002
    HI
    Hi everyone! Have a question on tranferring an original 1970 Z-28 instrument guage cluster to another 1970 camaro.
    I removed the Z-28 cluster with all the wiring and harness together in one piece. It seems that the harness all come together and join at one terminal junction block.
    I was wondering if, I could just plug and connect the terminal block into the 70 camaro? Will cluster work? The only wire that is not part of the harness is the coil wire for the 8000rpm tach. Do I need different sensor/switches i.e oil,water for the Z-28 guages?
    Any info on this conversion would be helpful. Thanks
     
  2. XxWickedz28xX

    XxWickedz28xX Veteran Member Lifetime Gold Member

    5,981
    3
    May 22, 2001
    Carmel, NY
    I dont know for sure, but I would say it should work. Over the years Ive collected parts from various cars, and one of them was the gauge cluster. Ive put clusters in from a 76 into a 79 and everything worked ok. I remember reading somewhere that some water temp sensors might be different in some years, so you will get an "off" reading.
     
  3. gookc

    gookc Veteran Member

    358
    0
    Aug 9, 2002
    HI
    I guess the big question I have or problem is: the 70' camaro I'm installing the guage cluster did not come with guages. it only has idiot lights. So, I'm wondering if the Z cluster and harness will clip in to the car and will the guages work?
     
  4. GetMore

    GetMore Veteran Member Lifetime Gold Member

    2,870
    0
    Nov 8, 2004
    Patterson, NY
    I'm guessing here, but I believe they should clip in without a problem. However, you will not get proper readings on the gauges. You will have to install the correct sending units, (and here's the big guess) then you will have working gauges.
    The idiot light sending units are just on/off switches.
     
  5. Juicer28

    Juicer28 Member

    84
    0
    Jan 15, 2001
    Ft. Worth Texas
    Hi all, I have a 1980 Camaro, and purchased a Z28 cluster for it, and the main plug that you plug in the back, was not correct, Nothing worked, I did get the info from this forum I believe,, I now have a 1978 Camaro Z28, the Cluster in it, does not have a Tach on it, so I am going to be getting one, and hopefully the plug is correct, or I may need to do the same changes on the main plug.. Does anyone know if I put a 1980 Z28 cluster, will it work when I plug it in, or will I have to make changes to the wires,, Please helpl. I had to make a few changes when I installed the Z28 cluster, I had to make changes, it did not work right.
     
  6. steve_1978

    steve_1978 Veteran Member

    376
    0
    May 5, 2010
    ontario canada
  7. purpleflame

    purpleflame Veteran Member

    234
    0
    May 7, 2003
    west valley, utah USA
    This is very correct going from idiot lights to guages requires the swapping of the pins I did this in mine and it worked perfectly.
    good luck and enjoy the guages.
     

Share This Page