What could have caused this? Accel coil issue

Discussion in 'Electrical Systems' started by David79Z28, Oct 21, 2017.

  1. David79Z28

    David79Z28 Veteran Member Lifetime Gold Member

    1,264
    32
    Oct 22, 2009
    Greenville, TX
    This is how my coil looks after 8 years and 2400 miles.

    I'm replacing the cap, rotor, and coil. Could something else have caused this or will my fix correct the problem? I would hate to replace those only to have the issue occur again, SOONER than the last time.

    image.jpeg
     

    Attached Files:

  2. budro6968

    budro6968 Veteran Member

    1,207
    124
    Apr 2, 2016
    Jax Florida
    I have seen that before. It also burned through the rotor and arced to the Dist shaft. Probably just carbon dust build up from the button that eventually caused too much spark scatter. If your coil still looks OK Try to reuse with new parts.
     
  3. SRGN

    SRGN Veteran Member

    178
    49
    Feb 20, 2009
    Central NJ
    Could be a little too much resistance in the plug wires.
     
    dale68z likes this.
  4. BonzoHansen

    BonzoHansen Administrator Lifetime Gold Member

    I had a new accel coil short out a few years ago after about 2000 miles. junk
     
  5. Gary S

    Gary S Administrator Lifetime Gold Member

    20,631
    181
    Apr 14, 1999
    Bismarck, North Dakota
    I don't know how the Accel coil mounts in there, but when you use the factory style coils, there is a ground strap under it. That ground strap needs to be there or you will have short coil life.
     
  6. David79Z28

    David79Z28 Veteran Member Lifetime Gold Member

    1,264
    32
    Oct 22, 2009
    Greenville, TX
    Thanks guys. I got it running today.

    Made sure I installed the ground strap also..
     

Share This Page