Oil Pressure

Discussion in 'Troubleshooting & Diagnosis' started by Coadster32, Aug 1, 2017.

  1. Bandit723

    Bandit723 Veteran Member

    2,251
    262
    Oct 1, 2016
    Waupaca WI
    Don't know how to do the up arrow thing but +1 on the Wix 51061
     
  2. Dave Nelson

    Dave Nelson Veteran Member Gold Member

    3,076
    329
    Dec 19, 2003
    Vineland N.J USA
    I wouldn't waste my time using the "other Carquest 1/2 size filter". Why not return it for a different brand & size to see if the problem goes away? Wix are very good filters.
     
  3. Coadster32

    Coadster32 Veteran Member Lifetime Gold Member

    1,185
    41
    Oct 2, 2013
    Milford,CT
    So I worked it all out yesterday and last night. I saw a few videos online where a guy cuts open a bunch of new different brand oil filters just for comparison. Also noted someplace else that Wix, Carquest blue, and NAPA gold are the same filter with a different badge. Without having an issue with carquest blue, I called up Carquest and asked them for WIX#51061. They asked what car is it for, and that's when I chewed them out. Long story short, returned my shortie, came home with the longie, and swapped it out. Of course it was stubborn coming out though. Nothing a self tapper couldnt handle.
    20170803_165657.jpg

    I went to start the car back up, to see if this was the issue before doing the sending unit. Put the key in, turned the key. Before I fired it up, noticed the oil pressure gage was pegged. I didn't bother starting the car. I swapped out the sending unit, put the key back in, and it dropped to zero.
    20170803_180956.jpg
    The spade connector came out when I tried to unplug the unit. I guess I learned that if your oil pressure gage peggs, It lost signal alltogether. I would have expected the pressure to remain at zero. Thank you for all who chimed in, and steer this boat back on the road. Car ran good last night.
     
  4. CorkyE

    CorkyE Veteran Member Lifetime Gold Member

    8,811
    133
    Nov 4, 2004
    Ringgold, GA
    Glad you got it cleared up. Long gone are the days when you went into a parts store and simply asked for 1qt sbc filter, and the guy didn't even look at the book, just went in the back and brought it out.
     
  5. Bandit723

    Bandit723 Veteran Member

    2,251
    262
    Oct 1, 2016
    Waupaca WI
    Nice Job figuring this out....
     
  6. rocket dawg

    rocket dawg Veteran Member

    204
    11
    May 5, 2015
    Grand Rapids Mi
    Wix for me, Napa is the same filter. 2nd choice is Purolator or A/C Delco. Somewhat related oil problem with mine. The oil pressure needle would vibrate back and forth. After awhile the tip broke off the needle ( I have a spare gauge on my shelf ) I thought it was the MSD distributor throwing interference electrically. Chased this problem for 2 years with the MSD trouble shooting online. At the time I put a brand new oil pressure sending unit in when the problem surfaced. All along it was a bad brand new sending unit. I put new filters on, new wires to the sending unit, etc.... Nice steady needle now, 70/75 psi cold and 55-60 warm at speed. Nice to hear you got it figured out.
     

Share This Page