Low rpm stumble

Discussion in 'Troubleshooting & Diagnosis' started by Justin79maro, Dec 22, 2017.

  1. bourbon_scotch

    bourbon_scotch Veteran Member Lifetime Gold Member

    2,020
    52
    Jan 10, 2003
    USA
  2. Justin79maro

    Justin79maro Veteran Member

    103
    1
    Jan 15, 2015
    Bonne terre, missouri
    Yeah it seems to be fine. But when I unplug is the idle doesn't change and it's always been like that where is doesn't have any vacuum at idle. Do you think the vacuum Adv is going out?
     
  3. Gary S

    Gary S Administrator Lifetime Gold Member

    21,120
    312
    Apr 14, 1999
    Bismarck, North Dakota
    If you have full time vacuum on that line, it should change the idle speed. If you have ported vacuum, it might not change at all until engine rpms come up.

    It is fairly easy to check the vacuum advance. Put a hand vacuum pump on the line to the distributor. Pull the distributor cap so you can see inside the distributor. Pump up the vacuum and see if the advance moves in the distributor.
     
  4. Justin79maro

    Justin79maro Veteran Member

    103
    1
    Jan 15, 2015
    Bonne terre, missouri
    So I've cleaned the discharge nozzle. Check the fuel filter, replaced the vacuum Adv. And it still has the stumble and power loss between 1500-2000rpm. Not really sure what to try next. I guess I'll pull the carb apart and clean it unless anyone who has had this problem can tell me what it is lol
     
  5. Gary S

    Gary S Administrator Lifetime Gold Member

    21,120
    312
    Apr 14, 1999
    Bismarck, North Dakota
    Find a way to block the secondaries so they can't open. Then drive it again.
    If you can't block them closed, tighten the secondary adjustment so it opens later and give it a try.
     
  6. COPO

    COPO Veteran Member Lifetime Gold Member

    16,395
    283
    Sep 15, 1999
    Ontario, Canada
    Adjust the pump arm. You could also have a loose power valve.
     
  7. 80sz

    80sz Veteran Member

    2,701
    268
    Feb 2, 2014
    Buffalo,n.y.
    Did you check the choke to see if its opening and
    Staying open? It has 12 volts?
     
  8. cadillac_al

    cadillac_al Veteran Member

    613
    39
    Apr 22, 2015
    Maine
    I'm curious if the spark plug gap may be too wide.
     
  9. Justin79maro

    Justin79maro Veteran Member

    103
    1
    Jan 15, 2015
    Bonne terre, missouri
    I pulled the front bowl off and check the power valve and I changed the jets from 72s to 69s and the tears from 83s to 79s
     
  10. Justin79maro

    Justin79maro Veteran Member

    103
    1
    Jan 15, 2015
    Bonne terre, missouri
    Yes it stays open and it has a 12v source to it
     

Share This Page