How did I screw this up?

Discussion in 'Troubleshooting & Diagnosis' started by zekefreak, May 27, 2010.

  1. Philip

    Philip Veteran Member Lifetime Gold Member

    1,805
    5
    May 30, 2006
    Marana, AZ
    Thanks, glad that we figured it out, pictures always help.
     
  2. jthomas

    jthomas Veteran Member Lifetime Gold Member

    1,493
    54
    Dec 5, 2007
    NorthCentral PA
    Thanks!

    Philip and Zekefreak...

    I discovered the exact same issue with mine. I was working on getting my steering straight and couldn't...same issue as Zekefreak. My I/S was also the 90 degree rotated version. I have four others and found the correct one. Am rebuilding it now for installation this weekend.

    Philip...thanks for going that extra mile to help out. You solved a problem for more than one of us.

    This should be a sticky!
     
  3. Philip

    Philip Veteran Member Lifetime Gold Member

    1,805
    5
    May 30, 2006
    Marana, AZ
    I love the hard to solve problems, although they are easier to diagnose when the car is in front of me. I was unaware of the changes in the alignment of the ends of the shafts until I pulled several out last night. I knew the part numbers had changed but assumed that it was from the non serviceable boot GM started using.
    Isn't that why we are here to help others :D
    CPHCP :brightide
     
  4. zekefreak

    zekefreak Veteran Member Lifetime Gold Member

    1,532
    4
    Apr 16, 2006
    western PA
    And the Heavenly Choir sings "Aleluia". :)

    I'm just glad it wasn't something I did! I, too, like a challange but this was getting just frustrating.
     
  5. Philip

    Philip Veteran Member Lifetime Gold Member

    1,805
    5
    May 30, 2006
    Marana, AZ
    I purchased a new shaft for my 77 from Power Steering Services. Made a phone call and 4 days later it was at my door. I needed one from a G body because of the Cadillac steering column I used and no one else had the correct shaft.
     
  6. Philip

    Philip Veteran Member Lifetime Gold Member

    1,805
    5
    May 30, 2006
    Marana, AZ
    Dang zeke did you get any sleep?
     
  7. zekefreak

    zekefreak Veteran Member Lifetime Gold Member

    1,532
    4
    Apr 16, 2006
    western PA
    About 5 hours. We're having a picnic today and I have lots to do. Going out now to cut the grass.

    This thread became alot more involved than I ever anticipated. Thanks again, Phillip and to everyone who wrote. This is why The Nasty is so great!!
     
  8. jthomas

    jthomas Veteran Member Lifetime Gold Member

    1,493
    54
    Dec 5, 2007
    NorthCentral PA
    Thanks again guys. Just finished restoring and installing the correct I/S. Now everything is straight like it should be. Sweet!
     
  9. Marks71BB

    Marks71BB Veteran Member Lifetime Gold Member

    Good job Phillip!

    Glad ya got it all figgured out Zeke! I would never have guessed!
     

Share This Page