Help With Tach On '70 Z28

Discussion in 'Troubleshooting & Diagnosis' started by chevyles, Oct 22, 2017.

  1. chevyles

    chevyles Veteran Member

    161
    0
    Sep 12, 2000
    Bay area, CA
    Hi folks,
    I posted this in the electrical section but haven't had a nibble there.

    Many years ago I put an Accel 300+ ignition box in my '70 Z28. It has performed flawlessly and I have no desire to replace it- love the adjustable rev limiter. The problem is, as soon as it was installed I lost my tach- as in it simply doesn't work. The needle has sat at zero for all these years. FWIW, the current distributor is the MSD billet.

    A long time ago I got some info on a part that would supposedly fix the signal to the tach but the link for that product died before I acted on it- my bad. It really hasn't been a huge deal because I know the car so well (I'm the original owner), and I know the top speeds in each gear so I have good shift points when running it out. However, I'll be putting a 396 stroker in soon that will rev harder and have a different redline.

    So, I'm hoping one of the resident electrical gurus here will know how to solve this problem. It would be awesome to see that needle moving again! Thanks for whatever help anyone can provide.
    Les
     
  2. SRGN

    SRGN Veteran Member

    178
    49
    Feb 20, 2009
    Central NJ
  3. chevyles

    chevyles Veteran Member

    161
    0
    Sep 12, 2000
    Bay area, CA
    Awesome! There can't be many left out there from what I just saw. I found one on Ebay and pulled the trigger. I can't thank you enough. :bowtie:
     

Share This Page