Help with my 99 Expedition

Discussion in 'The BS Topic' started by edge, Apr 10, 2006.

  1. edge

    edge New Member

    16
    0
    Jun 6, 2005
    southern Wisconsin
    Hello, I own a 99 EB Expedition. A few weeks back it seemed like my brakes were locking up so I replaced them all around. The symptoms were that when I would make sharp low speed turns it felt like I was in low 4 wheel drive, jerking and even stopping the truck. Now that I replaced the brakes it is still doing it. Can it be something in the transfer case or??? thanks.
     
  2. Joekool

    Joekool Veteran Member

    5,887
    25
    Feb 4, 2002
    Hollister CA USA
    Does the abs light come on? Sometimes metal, rust and dirt build up around the wheel speed sensors and they can give false readings to the ABS control module which could allow the brakes to lock up or do funny things.
     
  3. edge

    edge New Member

    16
    0
    Jun 6, 2005
    southern Wisconsin
    Yes the ABS light has been on for a while in fact it was on prior to the problem. I am going to replace the rear wheel speed sensor to see if that shuts the light off.
     
  4. GetMore

    GetMore Veteran Member Lifetime Gold Member

    2,870
    0
    Nov 8, 2004
    Patterson, NY
    Install Firestone tires.
    Probably not the kind of fix you want.
     
  5. Knuckle Dragger

    Knuckle Dragger Moderator Staff Member Lifetime Gold Member

    13,285
    469
    Nov 2, 2002
    Waddell AZ
    Fix the abs first. If it's still there then email me the vin number and I'll run oasis (Ford database for recalls and TSB) and we can go from there. IT could be a multitude of things, but like Joe said the abs is a good place to start since it's already a know problem.
     
  6. rscamaro73

    rscamaro73 Administrator Staff Member

    Besides the speed sensors....check the cap of the master cylinder. If the rubber on it is swollen then the fluid is prolly contaminated .....

    BUT.....

    if you KNOW its one of the wheel speed sensors...then try that first....
     
  7. edge

    edge New Member

    16
    0
    Jun 6, 2005
    southern Wisconsin
    how do I know if my truck has RABS or 4WABS, thanks?
     
  8. Knuckle Dragger

    Knuckle Dragger Moderator Staff Member Lifetime Gold Member

    13,285
    469
    Nov 2, 2002
    Waddell AZ
    Look for sensors at the front wheels. No sensors it RABS. The rear sensor has a high failure rate in both systems.
     
  9. louiechevy

    louiechevy Veteran Member

    163
    0
    Nov 24, 2000
    England
    they do sufer from a problem with the four wheel drive that can be either the ecu or the steper motor on the transfer case that can cause syptom's the same as you have from memory they get stuck in four wheel drive and then when you turn tight a low speeds it feels like one of the axles is locking up hope this helps
     
  10. edge

    edge New Member

    16
    0
    Jun 6, 2005
    southern Wisconsin
    well I replaced the ABS sensor and the light went off but did not fix the brake problem???
     

Share This Page