Help finding a 1974 camaro gas tank sending unit (2 lines)

Discussion in 'Camaro Questions' started by Sparx, Apr 7, 2008.

  1. BUSHY 409

    BUSHY 409 Veteran Member

    350
    0
    Nov 25, 2006
    Acworth GA.
    Sounds like A ground prob. also you mite think about the the dash board printed hicky thing
     
  2. Tpx

    Tpx Veteran Member

    Yes my '74 had a canister. I promptly removed that and the line that ran to the gas tank. Useless and un-needed.
     
  3. Sparx

    Sparx Member

    65
    0
    Jul 20, 2007
    Nebraska
    I droped my tank and pulled the sending unit, it ohmed good. B4 pulling the tank I pulled the instermint cluster, and it all looked good and it all ohmed good, so as far as I could tell its good. wiring ohms good and looks good all the way, unless I missed something, but my guess now is a Bad gas gauge. just can't not have a working gas gauge unless theres any other ideas someone has ? anyone have a used gas gauge they would part with ?



    I built this 74 for my son that will be 16 in june, its way to strong for a 16yr old. its a 400SBC with stock cast crank, forged pistons, scat I beams, #187 camel hump heads with a healthy cam and 10.7:1CR with a weiand alum intake & Holley 750 DP, hooker headers, M21 4 speed and 342 geared 10bolt posi,the 3" exhaust with round open race mufflers that goes back to in front of the rearend and dumps down. I drove it, then my son drove it, then I pulled the secondary linkage off to slowvhim down a little. he don't know I did that, but he said the other day. its not got what it had, why ? I played dumb, and said Hum. we put centerlines on it with new bias ply Mickey Thompson tires on it. we added a line lock, worked on enterior a little. he will drive it some this summer then we will work it over next winter again with interior work and cowl hood ect.. its not his daily driver and not perfect or done yet. but it's nice, and it looks good. I will try and get pics today and post em. pretty cool ride for a 16yr old imo




    thanks everyone
     
  4. Sparx

    Sparx Member

    65
    0
    Jul 20, 2007
    Nebraska
    I got the gas gauge working. I dropped the tank and ohmed the sending unit, all was good. I found a complete gauge cluster out of a 78 or 79 Camaro. it was a different than my cluster, but it was complete and it had a tach ect. I was able to pull the gas gauge out of it, and put it in my 74 cluster. it had all the tabs ect. broke off of it. so it wasn't a cherry, but it served my needs. I gave $35 for it. thanks everyone for your help !
     
    Last edited: May 7, 2008
  5. olstyle

    olstyle Veteran Member Lifetime Gold Member

    8,648
    0
    Jan 27, 2008
    Crestwood IL.
    good job, glad ya got it working. but..............now ya got a 74 with a gauge that says "unleaded fuel only" but if you don't mind, thats what counts.
    Way to go.
     
    Last edited: May 8, 2008
  6. Sparx

    Sparx Member

    65
    0
    Jul 20, 2007
    Nebraska


    Doh WoW thats funny, cause I didn't notice it. but it's prob there huh ? I'm heading out to the garage soon. to pull the chrome off the around the back glass, so I can pull out the glass and clean it all up. so the local 1 man body shop here can real seal it, and put the trim back on. it's leaking at the top. wheel hop is my biggest issue now.

    [​IMG]

    [​IMG]

    [​IMG]
     
  7. thedude327

    thedude327 Veteran Member

    778
    0
    Feb 21, 2004
    Brighton,Michigan U.S.A.
    Mike, that would make a good tips and tricks post...........using a 76-later sending unit and trimming the lines back to where the original 74's ended for someone who was trying to keep the stock look as much as possible. My $.02
     
  8. thedude327

    thedude327 Veteran Member

    778
    0
    Feb 21, 2004
    Brighton,Michigan U.S.A.
     
  9. Sparx

    Sparx Member

    65
    0
    Jul 20, 2007
    Nebraska
     
  10. Sparx

    Sparx Member

    65
    0
    Jul 20, 2007
    Nebraska
    yup it says "unleaded fuel only" we took the chrome trim off the rear glass. one of us got in side and pushed out and the glass starting raising in top LH cornner. we worked it around and out it came. we cleaned all tthe sealant off the car and glass. now the body man can put the glass in next week. the package tray was covered with some fuzzy black thin carpet crap, and everything under that was water damaged. no rust. they had the trim off the back glass when they painted the car (the car was painted B4 we bought it, it was a garage paint job with a poor prep job b4 paint) and maybe the glass out also, looks like clear calking was used to try and seal it several times. but with a razor blade / trash can and a shop vac, it cleaned up nice. all thats left for a package tray is just metal. what goes back there ? and where do you get it ? we may paint the metal black under the package tray while the glass out, as it's a burnt red in color now, thats the original color of the car. lots of things to do to it, but it's a good starter.
     

Share This Page