factory tach not working

Discussion in 'Troubleshooting & Diagnosis' started by granitecowboy, Dec 16, 2011.

  1. granitecowboy

    granitecowboy New Member

    21
    0
    Dec 15, 2011
    milwaukee, wi
    Hi...new here. Just bought a 1980 Z28. Love the car but the tach doesnt work. Is this a common problem on these cars? The guy I bought it from said he couldnt figure it out so he just put an aftermarket tach in it.

    Any help in finding the problem would be appreciated!

    Thanks, Adam
     
  2. Gary S

    Gary S Administrator Lifetime Gold Member

    20,639
    182
    Apr 14, 1999
    Bismarck, North Dakota
    The most common problem for tachs is that they get disconnected from the distributor. Connect the factory tach and inspect the wire through the tach filter to the firewall. If you don't find a problem there, your problem lies in the dash or the tach itself.
     
  3. Twisted_Metal

    Twisted_Metal Moderator Staff Member Lifetime Gold Member

    25,270
    286
    Feb 26, 2004
    Bloomington, MN
    What does the tach needle do....
    Does it go to "zero" when you turn the key?


    If the rest of the gauges are working... You have power and ground to the cluster.
    There should be a brown wire coming through the firewall near the brake booster. It needs to be connected to the front/left connector on the drivers side of the distributor cap. (Where the aftermarket tach is plugged in.)


    Welcome to NastyZ! :D
     
  4. scooterr68

    scooterr68 Member

    32
    0
    Feb 2, 2011
    Boston,MA
    my 1979 tasch does not work well either...its off a bit. Had problems with the temp gage as well
     
  5. granitecowboy

    granitecowboy New Member

    21
    0
    Dec 15, 2011
    milwaukee, wi
    Hey guys thanks for the help! Ill check it out over the weekend but it looked like everything was hooked up properly when I looked at it yesterday. The needle appears to be stuck around 1200 rpm or so...it never moves. Im assuming the tach is broke. Are there easy fixes with them or should I just try to find a new one? Is there anywhere that I can even buy a factory tach?

    Just bought the car yesterday. Ran it through the gears a few times today...its fun. Too bad I have to park it all winter....

    Thanks again.
     
  6. Twisted_Metal

    Twisted_Metal Moderator Staff Member Lifetime Gold Member

    25,270
    286
    Feb 26, 2004
    Bloomington, MN
    The swap meet section or eBay for a factory tach.

    If it has the long orange needle and there is no redline markings below 4500 rpm... It the correct tach for your 80Z.
    (Lower redline means it's a V6 tach. Shorter red needle means it's pre-79)

    The proper replacement should look like this.
    [​IMG]
     
  7. 76 camaro car 1

    76 camaro car 1 Veteran Member

    2,320
    2
    Apr 23, 2010
    St.Augustine,Florida
    My tach works fine and it also rest around 1200 rpm until power is put to it and then it goes to 0. I think all factory tach's rest in that area when the key is off.
     
  8. Twisted_Metal

    Twisted_Metal Moderator Staff Member Lifetime Gold Member

    25,270
    286
    Feb 26, 2004
    Bloomington, MN
    It may not be getting power due to a poor connection on the back of the cluster or the point where it plugs into the harness.

    It could be a toasted component in the tach itself too.
    It's awfully hard to tell without removing the cluster from the car some times.
     
  9. granitecowboy

    granitecowboy New Member

    21
    0
    Dec 15, 2011
    milwaukee, wi
    cool cool...Ill have to take it out of the dash and check things out. I see Yearone makes tachs for 70-78 cars but no 79-81's....will a 70-79 tach fit? I dont care what the redline starts at as long as its an accurate gauge.
     
  10. granitecowboy

    granitecowboy New Member

    21
    0
    Dec 15, 2011
    milwaukee, wi
    And what is up with this car having a clock in a place where GM soul have put an oil pressure gauge?? Im almost thinking of putting an oil pressure gauge from an earlier model in its place....anyone know if that would fit properly?
     

Share This Page