Crate engine exhaust smoke

Discussion in 'Troubleshooting & Diagnosis' started by S_ghost, Aug 3, 2017.

  1. badazz81z28

    badazz81z28 Veteran Member

    14,603
    158
    May 4, 2001
    Las Vegas, NV
    Even a brand new engine with the rings still seating will not smoke. What did the break-In instructions tell you to do? I would get BP on the phone. I would guess valve seals....they do get damaged on install at times.
     
  2. S_ghost

    S_ghost New Member

    11
    0
    Aug 3, 2017
    I *MAY* have located the problem. I think it may indeed be my intake. I noticed traces of oil on both sides between the manifold and heads, and found a couple small pools of oil on the intake itself where it looks like it was coming out around the bolts. I tightened them a bit but I may have to rip it off when I get the time... Or get my mechanic to do it... Also I have been keeping an eye on my dipstick and haven't seen a noticeable change in the level so it doesn't seem to be burning it very much.
     
    Last edited: Sep 5, 2017
  3. CorkyE

    CorkyE Veteran Member Lifetime Gold Member

    9,472
    252
    Nov 4, 2004
    Ringgold, GA
    Are the bolts toward the middle of the intake? Depending on heads, they generally are threaded into a open area in the engine galley and will wick oil unless thread sealer was used during install.
     
  4. S_ghost

    S_ghost New Member

    11
    0
    Aug 3, 2017
    The second from the front on both sides.
     
  5. badazz81z28

    badazz81z28 Veteran Member

    14,603
    158
    May 4, 2001
    Las Vegas, NV
    Is it a Vortec set-up?
     
  6. CorkyE

    CorkyE Veteran Member Lifetime Gold Member

    9,472
    252
    Nov 4, 2004
    Ringgold, GA
    Second one back on my Edelbrock heads go into the galley. If you're seeing oil around those 2 bolts, someone likely failed to use thread sealer. If the gasket is compromised in that area, it could be sucking oil into the intake track. Since this is a new BluePrint engine, I think it would be wise to contact them directly. They have replied to issues on this web site, so they do have a customer service that's responsive.
     
  7. S_ghost

    S_ghost New Member

    11
    0
    Aug 3, 2017
    No the engine came with aluminum heads. And it has a Weiand warrior intake.
     
  8. CorkyE

    CorkyE Veteran Member Lifetime Gold Member

    9,472
    252
    Nov 4, 2004
    Ringgold, GA
    If it's a complete BluePrint engine, using their heads, it's not Vortec style.
     
  9. S_ghost

    S_ghost New Member

    11
    0
    Aug 3, 2017
    Yeah, no its not. It has aluminum heads.
     
  10. S_ghost

    S_ghost New Member

    11
    0
    Aug 3, 2017
    Okay so I know this thread is old and I don't mean to necro it but I've done a little work on it and want to update and get opinions. We changed and sealed the intake gasket and bolts and found that Apperantly it was in fact leaking oil through there. The #8 plug and cylinder was the problem one so I had my mechanic do a compression leakdown test on it and he said it turned up fine. The smoke has gotten better and it doesn't seem to be as bad but it still puffs on cold start up. A local parts store carries a PCV valve that I think has a filter in it and I'm thinking about giving it a try. But otherwise with the leakdown test being fine I'm running out of ideas.
     

Share This Page