correct blower resistor and switch for 78 with a/c

Discussion in 'Electrical Systems' started by Rich Schmidt, Oct 14, 2017.

  1. Rich Schmidt

    Rich Schmidt Veteran Member

    4,102
    16
    Mar 27, 2010
    Denville NJ
    Title says it all. I am replacing the heater core on my 73 that has an a/c system from a 78. The blower runs slow and some of the positions don't work. I bought a blower motor and also want to replace the resistor and switch. I keep getting a Dorman number but it comes up because it fits 82 and later Camaros and 78 and later G-bodies but not 78 Camaros. I tried a 76 Camaro figuring that it would eliminate the 78 G-body factor and there are no results. Any ideas?
     
  2. Gary S

    Gary S Administrator Lifetime Gold Member

    20,687
    196
    Apr 14, 1999
    Bismarck, North Dakota
    Does the blower motor run slow on high speed? If so, the problem isn't with the resistor. The resistor is used to slow the motor for the lower speeds. If it is slow on high speed, the problem likely is low voltage due to small wiring or a problem in the relay for high speed.
     
  3. Rich Schmidt

    Rich Schmidt Veteran Member

    4,102
    16
    Mar 27, 2010
    Denville NJ
    I don't even know what speed it is on. I put the blower on off and it runs,I put it all the way high and it runs slow,I put it in the middle and it runs fast in one position and not at all in the other. That's why I am replacing everything I will be going thru the wiring connections while I have it apart. I figured that for a few bucks I wasn't even going to try diagnosing the parts and just replace everything.
     
  4. hogg

    hogg Veteran Member

    3,102
    26
    Dec 29, 2000
    pegram,tn.,cheatam
    I bought this one off ebay ,new ,i thank it was for late 70's truck or car ,just buy looking at the picture on ebay of how it was made. When it arived i rotated the bace 180% to fit my a/c box,, Been working fine for few years now. this was for my 70 r/s.
     

    Attached Files:

  5. Rich Schmidt

    Rich Schmidt Veteran Member

    4,102
    16
    Mar 27, 2010
    Denville NJ
    They make 2 different ones that look like that and neither of them is listed as fitting a 73-81 Camaro with A/C. I saw resistors that were listed for cars up to 1972 but that was it. I am sure that even with the wrong resistor the wires could be swapped around to make it work but I just can't figure out why nobody actually sells the one for our cars.
     
  6. hogg

    hogg Veteran Member

    3,102
    26
    Dec 29, 2000
    pegram,tn.,cheatam
    mine was not listed for a camaro. i thank trucks used them up in the mid 80's
     
  7. Radio Joe

    Radio Joe New Member

    9
    2
    Nov 5, 2017
    I have the same problem on my 81- Wiring was butchered by previous owner so havent figured out the cause yet, but mine runs fast on any speed EXCEPT HI. on HI it runs really slow. keep us informed what you find out with yours.
     

Share This Page