79 Maro, LED Turn Signal Lights Not Flashing

Discussion in 'Troubleshooting & Diagnosis' started by 79_maro, Jul 13, 2017.

  1. 79_maro

    79_maro New Member

    13
    0
    Jul 13, 2017
    I just bought LED turn signal bulbs for my 79 Camaro and for some reason they're not flashing. I did some research and found out it could be because of the turn signal flasher and that I may need a specific flasher? If someone could leave a link that'd be great. Just need some confirmation as to why my LED turn signals won't flash but my regular bulbs will flash when switched out. Thanks for the help.
     
  2. ssupercoolss

    ssupercoolss Veteran Member

    314
    47
    Nov 3, 2015
    PA
  3. Twisted_Metal

    Twisted_Metal Moderator Staff Member Lifetime Gold Member

    25,257
    284
    Feb 26, 2004
    Bloomington, MN
    You need TWO flashers.

    One for the signal lights and one for the hazards.
    The hazard flasher is in the fuse block.
    The turn signal flasher is on a pigtail of wire behind the dash near the heater control panel.
    (You can find it by looking for something which looks like the one in the fuse block.)
     
  4. 79_maro

    79_maro New Member

    13
    0
    Jul 13, 2017
    Ok well I bought a Novita LL552 long life flasher a while back that quotes, "Works with incandescent bulbs or a mixture with LEDS." Should this work with the LEDs or should I buy the specific one you linked because the flasher I stated above won't allow the LEDs to flash.
     
  5. 70 Proof

    70 Proof Veteran Member

    293
    15
    Sep 28, 2014
    Southern Utah
    From your description the Novita sounds like it should work. Since it doesn't I'd suggest you get one like Supercool linked to. However get one that is non-polarity specific. Look for NP or something similar in the flasher's part number. I bought one at Autozone. If you want to save a little money you can just buy one for the signal flasher alone and not the 4 way hazard flasher in the fuse block. But then your hazard flasher won't
    work with the LED, bulbs but how often do you use your hazard flasher? LED Flasher.jpg
     
  6. 79_maro

    79_maro New Member

    13
    0
    Jul 13, 2017
    So buy the one you put in the picture? And I don't even have hazards to be honest. The button to turn it on isn't on my steering column. Not sure why but whatever, I never use them anyways.
     
  7. 70 Proof

    70 Proof Veteran Member

    293
    15
    Sep 28, 2014
    Southern Utah
    Yes, look for one as pictured or similar. I grounded the blk pig tail to the ebrake as it was convenient and no hole drilling was necessary. Amazon is another good source.
     
  8. 79_maro

    79_maro New Member

    13
    0
    Jul 13, 2017
    Ok sweet thanks. Besides that is ther any other reason the LEDs may not be flashing? And besides NPD and Camaro Central, are the any good online places to get parts for my 79? Thanks again.
     
  9. 70 Proof

    70 Proof Veteran Member

    293
    15
    Sep 28, 2014
    Southern Utah
    Make sure your wiring is not screwed up with a lot of splices and that your sockets are clean and good to go. If your LED's don't work after you get a good flasher hooked up it could be due to a number of electrical gremlins.
    A quick internet search shows several ++ LED flasher units that claim to be 'plug and play' with no ground wire necessary. Memotronics EF32RLNP @ $12 on Amazon would be a good choice among others.

    As far as on line parts for your 79, the internet is your friend. There are a bunch of vendors of 2nd generation parts including some that advertise on this site.
     
  10. ssupercoolss

    ssupercoolss Veteran Member

    314
    47
    Nov 3, 2015
    PA
    Twisted is correct by the way....there are two. keep in mind, some if not all led's are polarity sensitive. like the little push in bulbs for side markers. if they dont work first go, turn them 180 degrees. and yeah, make sure the sockets are nice and clean. mine are so finicky.
     

Share This Page