Another 70 specific Q, e-brake light

Discussion in '1970 - 1973 Specific' started by badazz81z28, Jan 4, 2017.

  1. badazz81z28

    badazz81z28 Veteran Member

    12,898
    26
    May 4, 2001
    Las Vegas, NV
    i couldnt locate the exact e-brake light switch for my 70, but since the painless harness came with a spade connection on the harness I got a spade switch. Went to install it and it seems I don't have the guide hole nor does it seem like the other hole is in the right location.

    Anyone have a picture of how the 70 goes on?
     
  2. Green hornet

    Green hornet Veteran Member

    283
    14
    Oct 11, 2015
    North Bay, CA
    image.jpeg
    image.jpeg

    Here are a couple of photos of the switch in my 70. Sorry this is best photo I could get. Hope this helps.
     
  3. badazz81z28

    badazz81z28 Veteran Member

    12,898
    26
    May 4, 2001
    Las Vegas, NV
    Thank you, but I'm looking for the switch on the E-brake pedal
     
  4. Green hornet

    Green hornet Veteran Member

    283
    14
    Oct 11, 2015
    North Bay, CA
    image.jpeg image.jpeg

    Sorry my bad. Try this, again the best I could do. Hope this helps this time. Ha
     
  5. badazz81z28

    badazz81z28 Veteran Member

    12,898
    26
    May 4, 2001
    Las Vegas, NV
    Awesome, does anyone have it removed? It appears the 70 is different more then the spade connector. It doesn't even seem I can use the one I have. Dang 70 only again!
     
  6. badazz81z28

    badazz81z28 Veteran Member

    12,898
    26
    May 4, 2001
    Las Vegas, NV
  7. 70 SS/L78

    70 SS/L78 Veteran Member Lifetime Gold Member

    FWI... I don't have any pics and going from memory here. When I restored my car my new wire harness had a round terminal that connected to the e-brake switch, same as the original. I believe it was bare metal and completes a ground circuit when the e-brake is depressed. The circuit works the same way as the dome light, complete the ground to make the light come on.
     
  8. badazz81z28

    badazz81z28 Veteran Member

    12,898
    26
    May 4, 2001
    Las Vegas, NV
    My problem is actually bolting the switch to the frame. The newer switch doest seem like I can make it work
     
  9. 70 SS/L78

    70 SS/L78 Veteran Member Lifetime Gold Member

    Gotcha... now I understand you're problem. Not sure what year they changed styles? Someone here should be able to post a picture. Are you looking for a better picture of how the newer spade style switch mounts?

    Another thought... Do you still have your old switch & wire harness? If so, I would remove the connector from your old harness and solder it on to your new harness.
     

Share This Page