NastyZ28 Forum



Go Back   NastyZ28.com > Drivetrain & Performance > Engine Topic
User Name
Password

Reply
 
Thread Tools Display Modes
Old 08-17-2005, 10:00:00 PM   #1
mrsbojigger
New Member
 
Join Date: Aug 2005
Location: san antonio, tex. usa
Posts: 16
engine offset

Installing LS1 engine into '80 Camaro. I have measured from side to side with engine in place. The engine sets 1" to the right (passenger side). Is this correct? Is this to factory specs? My mechanic doesn't know. I know my Hudson has an offset engine.
Chaz
mrsbojigger is offline   Reply With Quote
Old 08-17-2005, 10:34:00 PM   #2
retorq
Veteran Member
 
Join Date: May 2003
Location: Kingman, AZ
Posts: 4,923
Yes, I ran into the same thing when I cut a 16 inch hole in the center my hood for the air cleaner!! I ended up having to cut it to 18 to get it to look right. I was told it was normal and due to the steering linkage.
__________________
The first digital hijinx I designed was quite naturally perfect. It was a work of art. Flawless. Sublime. A triumph only equaled by its monumental failure.
retorq is offline   Reply With Quote
Old 08-18-2005, 12:02:00 AM   #3
80'427
Veteran Member
 
Join Date: Jan 2005
Location: Fairbury, NE, USA
Posts: 1,886
I will tell you after changing plugs in my 99 firebird tonight the factory LS1 sits closer to the pass side by at least a inch if not more.
80'427 is offline   Reply With Quote
Messages from Our Sponsors !
Awesome NastyZ28.com Merchandise !!

T-shirts, wearing apparel

Drinkware, Mouse Pads, Decals

Old 08-18-2005, 09:14:00 AM   #4
mrsbojigger
New Member
 
Join Date: Aug 2005
Location: san antonio, tex. usa
Posts: 16
Thanks Guys,
Chaz
mrsbojigger is offline   Reply With Quote
Old 08-19-2005, 12:00:00 AM   #5
dgwar
Veteran Member
 
Join Date: Mar 2005
Location: Santee,South Carolina
Posts: 555
I had the same problem when I put my Big Block in...turns out I missed the hole on the motor mount. bolt went through the outside mounting holes fine and missed the inside mount hole.
I jacked that side back up and slid the inside mount back in place installed the bolt and now it sets level.

------------------
__________________
1981 Camaro Coupe
402 auto.
http://www.home.earthlink.net/~dgwar/
dgwar is offline   Reply With Quote
Reply




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



Copyright © 1997 - 2014 NastyZ28.com Inc.
Powered by vBulletin Version 3.5.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.