NastyZ28 Forum



Go Back   NastyZ28.com > Regional Discussion, Events & Clubs > Canadian Owners
User Name
Password

Reply
 
Thread Tools Display Modes
Old 07-06-2012, 02:11:12 PM   #61
twood
Veteran Member
 
Join Date: Feb 2012
Location: Glen Morris, ON Canada
Posts: 336
Quote:
Originally Posted by z28inprogress
Vancouver here. Car is sitting in Alberta at the moment.

Pics???? Info????
Why is it sitting in Alberta?
Cheers
__________________
Tony

1981 Sport Coupe
350 TH400, Shift kit, 4:11 rear end
If You haven't Grown Up By The Age 50...You Don't Have To
twood is offline   Reply With Quote
Old 07-12-2012, 01:53:41 PM   #62
twood
Veteran Member
 
Join Date: Feb 2012
Location: Glen Morris, ON Canada
Posts: 336
bump
__________________
Tony

1981 Sport Coupe
350 TH400, Shift kit, 4:11 rear end
If You haven't Grown Up By The Age 50...You Don't Have To
twood is offline   Reply With Quote
Messages from Our Sponsors !
Awesome NastyZ28.com Merchandise !!

T-shirts, wearing apparel

Drinkware, Mouse Pads, Decals

Old 07-25-2012, 01:39:43 PM   #63
twood
Veteran Member
 
Join Date: Feb 2012
Location: Glen Morris, ON Canada
Posts: 336
My first small, long trip

This post is going to take a long time to do. I normally use the two finger hunt and peck method, but now im down to 1, my left hand...lol... Im afraid ill get logged out before i finish!!!!!!
As I mentioned in my last post the camaro is on the road....(but everyone would know this if your reading my posts lol )
I had a couple days before my surgery and i really wanted to go to Kitchener (which is appr. 50 kms away) to pick up my son and do some running around. This would be my first good legal run since i bought the car. I made an appointment with the appraiser, got insurance for the day, and was good to go. I havent been this excited in a long time. I was hoping Murphy stayed behind. I was wrong and i made one critical mistake...in all my excitement i forgot to put my toolbox in the trunk....anyways, back to my adventure...

Everything was running great. I was getting dizzy checking my gauges. Oil pressure was staying around 35-40, doing 80-90 kph (50-55mph) good (i think? I heard that oil pressure should read around 10psi for every 1000rpm)
Temp. was around 190 until i was about 30kms on the highway. The temp was starting to creep up to 200. When i hit the city,it was at 210. By the time i arrived at my sons, which was around 5 kms of stop and go driving, it was staying around 220 on the gauge. It never went any higher. It was a warm day, around 80 degrees, 92 with the humidex. I let it cool down and checked the coolant level and it was okay. I have a clutch fan but no shroud, and no air dam underneath. Now i know i need to do both soon.

We left after the car cooled and did some errands, and on the way back to my sons, i got a wiff of oil and as i pulled up to a stop light, all hell broke loose. Smoke started to bellow out from under the hood. It was so bad, it was coming in the cabin....I made a quick right into a plaza that was on the corner, and shut her down as fast as i could. I was lucky i could do that and not shut her down in the middle of an intersection... A thousand things were going through my head. Oil was just issing on the ground, coming from the back of the engine. Then it stopped by the time i opened the hood. Im looking around and see the oil line for my guage not attached to the fitting behind the carb. (didnt want to use this type of guage, but the electronic led one was giving me problems and this was all i had.). The oil sprayed out all over the firewall, tranny, and headers. That explains alot...WTF
...AND HERE I AM WITH NO TOOLS....stranded in the middle of the city....BUT WAIT...there's a doller store and a gas station next door.
First the doller store... an adjustable wrench, assorted nuts bolts and screws, paper towels, electrical tape and a multi bit screw driver. Its McGiver time. I (finally) got the fitting off with that cheap-ass wrench and the brass crimped peice was inside. Then i plugged the fitting with my assortment of supplies and put it back on.
Now the oil...went next door to the station and bought 3 litres, checked it and it was down 2+ litres.
Started it up and it held tight. Smoked a little, but not much of a burn off. Ran good. WHEW...You should see the oil patch i left for the plaza...I felt bad, but you know...i guess ill stay away from that area for awhile,...lol
Needless to say i missed my appraisal appointment. Thats where i was going after i dropped my son off. I called and he is coming to my place for an extra $30. i'm unable to drive anyways for 6 wks and I need the insurance done...
Well, i did make the trip home with no problems. Temp was around the 225 mark again, so that conforms the shroud and air dam theory.

Cheers

p.s. I did have to log back in LOL
__________________
Tony

1981 Sport Coupe
350 TH400, Shift kit, 4:11 rear end
If You haven't Grown Up By The Age 50...You Don't Have To
twood is offline   Reply With Quote
Old 07-25-2012, 03:42:19 PM   #64
71camaroz27
Veteran Member
 
Join Date: Jun 2011
Location: SW Ontario
Posts: 288
Glad you got her back home safe and sound. Ya the shroud will definitely make a difference with the mechanical fan.
How long till you can drive again?
71camaroz27 is offline   Reply With Quote
Old 07-25-2012, 05:12:20 PM   #65
twood
Veteran Member
 
Join Date: Feb 2012
Location: Glen Morris, ON Canada
Posts: 336
The sling comes off in around a month from now. As soon as that happens, i still have to take it easy, but its an automatic...lol
__________________
Tony

1981 Sport Coupe
350 TH400, Shift kit, 4:11 rear end
If You haven't Grown Up By The Age 50...You Don't Have To
twood is offline   Reply With Quote
Reply




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



Copyright © 1997 - 2014 NastyZ28.com Inc.
Powered by vBulletin Version 3.5.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.